RStudio Desktop Freezes on Open (Windows 10)

I just installed RStudio for the first time since someone showed me I could make RevealJS slides from Markdown. However, everytime I open RStudio (open source desktop version), it freezes. I can move the mouse for a few seconds or perhaps click once (menu, button, etc.), but the program hangs and needs to be restarted.

I have tried uninstalling / reinstalling three times, but each time I get the same behavior. Does anyone have any advice on how to solve this problem?

@rob7
Which R version did you installed and under which path?

I installed RStudio 1.2.1335 - Windows 7+ (64-bit).

I used the default install location, and I installed as my own user, and then I also tried installing as administrator. Is that what you mean?

Hi @rob7!

I think @squeezer44 might have been trying to find out if maybe the hang happens when RStudio tries to start up R, in which case the culprit might be a problem with your R installation. (If you read that sentence and suddenly felt :dizzy_face:, you might want to take a look at: Differentiating R from RStudio).

Do you remember how you installed R?

Can you open Rgui.exe (the simple GUI that gets installed when you install R)? Does it seem to work OK? What do you get if you run sessionInfo() from the console in Rgui.exe?

2 Likes

Thank you both!
@jcblum When I saw your post, I reinstalled both R and R Studio as administrator, and I works! I may have only installed R Studio (not R) as admin initially.

Thank you for your advice!

1 Like

Glad you're up and running! :grinning:

If your question's been answered, would you mind choosing a solution (totally OK to choose your own post)? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

No problem!

I chose my own post a solution because it explicitly had the steps I took to resolve the issues (which I thought would help future users).

I wouldn't have tried again without both of your comments though!

Rob

1 Like

Unfortunately, I'm having the same problem before. RStudio opens and responds to a few clicks, the flashes, and is unresponsive. It seems to happen everytime I open it.

Referring back to @jcblum 's comment, I am able to run Rgui.exe, and it seems stable. Here is the open from sessionInfo()

R version 3.6.1 (2019-07-05)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 17134)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.6.1

Also for reference, I installed the following as administrator:
R 3.6.1
RStudio 1.3.1335

Oh no, sorry to hear that! :worried:

Someone had a superficially similar problem recently that seems to have been an interaction with a background program. A next step might be to read through that thread and see if any of the troubleshooting steps help you, too?

Thank you so much @jcblum for your suggestions. I haven't gotten it to work still. Unfortunately the semester is beginning so I'm going to set this project aside.

At the moment, I using a different program to convert markdown files to slides, and perhaps I'll try to get this working later.

1 Like

Would be very interesting to know what your baseline problem was - could you post it in here?

Unfortunately I was never able to identify why it was freezing.

Where is your working directory set?

We've found that if we have our default working directory set to a network drive (h:) rather than C:, RStudio is so slow that it's unusable. This wasn't always the case though - only seems to be a relatively recent thing.. Our h: drive is also available offline via Offline Folders, so that might be another complicating factor.

We've also noticed that when we try to create a new R script and use Save As to save to h: drive, it never actually saves. Anyone having this issue?

At least on my system, I don’t think the location was at fault since I was on the C: drive.

Since this seems like a substantially different question, would you mind posting it as a new topic? (we do like to keep things tidy around here :grin: :broom:)

What version of RStudio are you running? There's been a number of network-drive-related issues filed in the past, and development effort toward resolving them. Since network drives don't seem to be involved in @rob7's problem, probably best to also open a new topic if you want more help with this?


@rob7
I remembered that there were reports in the past of some anti-virus software (including Windows Defender) causing freezes and extreme slowness in previous versions of RStudio:

I don't know if this is even likely to still be a source of problems (the IDE team may have long since made changes that work around such issues), but maybe something else to look at?

I'm not sure if this is what you meant or not, but if you were originally interested in the revealjs R package, note that it's not dependent on RStudio: https://github.com/rstudio/revealjs#rendering