RStudio Desktop Issue with Catalina

Hi, and welcome!

Please see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers. This question, though, doesn't benefit from one.

RStudio Desktop works on my macOS, so the trouble probably is very likely that the underlying R program is missing. Think of RStudio as simply a graphical user interface to R. To install R, go to the CRAN download page for macOS.

If you are running Catalina, I strongly recommend downloading and installing from the notarized version. For earlier macOS, it may not be necessary.

I do know that RStudio needs to run on R. Yes. I am using Catalina. I have been a RStudio (and R) user for quite some time. I just signed up today because RStudio CMO (Rob Hewardt) told me to report the issue here.

I also read your replies for this post.

Due to COVID-19, it is not an option for me to reset my Mac (work laptop).

I can re-install and will try! Will keep you posted!

I cannot reinstall MacOS.

1 Like

I tried to re-install both R and RStudio. It showed up again as the previous post. The problem cannot be solved.

1 Like

I've heard several reports that R-3.6.3 throws errors on Mac OS, but that installing R-3.6.2 resolves these.

1 Like

I've seen several reports also involving R-3.6.3 and haven't been able to confirm my strong suspicion that it is due to installing the wrong flavor. With .3 and forward the preferred flavor is notarized.

macOS Catalina users must use notarized version which enforces hardened run-time. All others can use regular version which uses the same runtime as previous R releases. R 3.6.2 was the last version that can be run on Catalina with regular runtime

This version is named as usual R-3.6.3.pkg; the downversion R-3.6.3.nn.pkg (regular) will only run on Sierra and progeny up to but not including Catalina.

I downloaded R-3.6.3 notarized version. It did not work.

Could you pls forward the link for downloading R-3.6.2, pls?

Thanks for both answers/replies.

says the download page at CRAN. Following the same link through the CRAN welcome menu (the URL doesn't change, or I'd be able to give you a direct link) to macOS downloads, the regular version appears directly below the notarized version.

I lack the fortitude to test CRAN's must have assertion, but installing 3.6.2 should also fail if it's accurate.

Yes. @technocrat You are correct. I tried 3.6.2. It did not work either.

1 Like

OK, one more possibility before I'm officially out of magic.

In RStudio's menu if you can keep it from crashing long enough there is an option under Tools | Global Options | General | Advanced | OS Integration to switch from the default autodetect to software. My Airbook 2015 works fine on autodetect, but I've seen reports that later hardware that doesn't work on the default does work with the software option.

Sorry, did not work! :frowning:

My device is MacBook Pro (2018)

I really wished I knew how the other person fixed it. Maybe reset the whole Mac?

1 Like

There's more discussion of this on RStudio's issue tracker:

If you skim that for _GEKillDevice you can see some other users with the same issue. Some of them have posted steps that have worked for them.

We have never been able to reproduce this internally, but the best guess at this point is that some wires are getting crossed between R versions. The next thing I'd suggest is to fully remove your R installations from the terminal (a regular uninstall doesn't always clean up all the files).

Finally, the diagnostic screenshot you're sharing indicates that you're on the preview release. Preview releases get updated with bugfixes very frequently, so it's likely you're out of date. It'd be helpful to know if you still see this with the very latest preview (1.3.937) and the 1.2 release (1.2.5033).

2 Likes

Factoid: my macOS is on 1.3.820 without any glitches at all

You are awesome!!! Thanks a lot! I got it fixed following the steps of the link you sent.

Thank you all for your replies, trying so hard to help me! I really appreciate it!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

@rachelwindsor, sorry if I guessed wrong about your stage of R learning--it can be hard to tell and I tend to err on the side of underestimating.

I'm not sure what @tobias meant by "resetting." I should have asked. I don't think he meant re-installing the macOS. If he meant re-installing R and you mean that you can't because you don't have admin privileges on your work laptop, I'm reduced to suggesting RStudio Cloud which is about as good as SAAS gets, at least among those I've used.

As always, I could have misunderstood, so please come back if I have.

Dang! I just checked hoping that there might have been a compile from source option that could have resulted in the symbol not found error. I'm down to suggesting seeing if the same thing happens on the RStudio Pro trial version. If it still occurs, my sometimes reliable gut instinct is it's a permission issue that needs root privileges to fix.