RStudio Desktop won't open up after downloading on Mac OS 10.15.3

Hi!

I'm trying in install RStudio, but immediately downloading the program and trying to run it, it shuts down. Can anyone help me run it? Thanks!

This message pops up with the crash notification:

Process: RStudio [52218]
Path: /Applications/RStudio.app/Contents/MacOS/RStudio
Identifier: RStudio
Version: 2022.07.1+554 (2022.07.1+554)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: RStudio [52218]
User ID: 501

Date/Time: 2022-09-07 20:34:32.990 -0400
OS Version: Mac OS X 10.15.3 (19D76)
Report Version: 12
Bridge OS Version: 3.0 (14Y908)
Anonymous UUID: 839E4A3B-DD9C-9D14-FF44-6480DB909DCA

Sleep/Wake UUID: A615E400-6A97-4A34-B3AD-64734B89CBF3

Time Awake Since Boot: 3000 seconds
Time Since Wake: 730 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: EXC_I386_GPFLT
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [52218]

Application Specific Information:
/Applications/RStudio.app/Contents/MacOS/../Frameworks/libcrypto.1.1.dylib

Thread 0 Crashed:
0 libcrypto.1.1.dylib 0x000000010efd2a74 DYLD-STUB$$getenv + 0
1 dyld 0x0000000106ae2320 ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 990
2 dyld 0x0000000106ae2582 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
3 dyld 0x0000000106adcdc7 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 493
4 dyld 0x0000000106adcd32 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 344
5 dyld 0x0000000106adcd32 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 344
6 dyld 0x0000000106adcd32 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 344
7 dyld 0x0000000106adae58 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 188
8 dyld 0x0000000106adaef8 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 82
9 dyld 0x0000000106ac96b1 dyld::initializeMainExecutable() + 199
10 dyld 0x0000000106acecd0 dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 6797
11 dyld 0x0000000106ac8227 dyldbootstrap::start(dyld3::MachOLoaded const*, int, char const**, dyld3::MachOLoaded const*, unsigned long*) + 453
12 dyld 0x0000000106ac8025 _dyld_start + 37

Thread 1:
0 ??? 0x00007fff6fa38818 0 + 140735066376216

Thread 2:
0 ??? 0x00007fff6fa38818 0 + 140735066376216

Thread 3:
0 ??? 0x00007fff6fa38818 0 + 140735066376216

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000106b5d268 rbx: 0x000000010eeb82e0 rcx: 0x00007ffee9df5c40 rdx: 0x00007ffee9df5be0
rdi: 0x000000010efff5c3 rsi: 0x00007ffee9df5bc8 rbp: 0x00007ffee9df0800 rsp: 0x00007ffee9df07d8
r8: 0x0000000106b5d330 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x00007fff99645218 r13: 0x00007ffee9df0880 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x000000010efd2a74 rfl: 0x0000000000010246 cr2: 0x000000010f046b10

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 13

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 2887
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=749.8M resident=0K(0%) swapped_out_or_unallocated=749.8M(100%)
Writable regions: Total=559.5M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=559.5M(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Activity Tracing 256K 1
Kernel Alloc Once 8K 1
MALLOC 164.2M 18
MALLOC guard page 16K 3
MALLOC_NANO (reserved) 384.0M 1 reserved VM address space (unallocated)
PROTECTED_MEMORY 4K 1
STACK GUARD 56.0M 4
Stack 9752K 4
VM_ALLOCATE 56K 4
__DATA 43.1M 380
__DATA_CONST 388K 10
__FONT_DATA 4K 1
__LINKEDIT 362.3M 51
__OBJC_RO 32.0M 1
__OBJC_RW 1780K 2
__TEXT 387.7M 368
__UNICODE 564K 1
mapped file 27.2M 2
shared memory 48K 6
=========== ======= =======
TOTAL 1.4G 859
TOTAL, minus reserved VM space 1.1G 859

Model: MacBookPro13,2, BootROM 264.0.0.0.0, 2 processors, Dual-Core Intel Core i5, 3.1 GHz, 8 GB, SMC 2.37f21
Graphics: kHW_IntelIrisGraphics550Item, Intel Iris Graphics 550, spdisplays_builtin
Memory Module: BANK 0/DIMM0, 4 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C3531324D3332443250462D3039
Memory Module: BANK 1/DIMM0, 4 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C3531324D3332443250462D3039
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x157), Broadcom BCM43xx 1.0 (7.77.106.3 AirPortDriverBrcmNIC-1440.1)
Bluetooth: Version 7.0.3f5, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
USB Device: Apple T1 Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 41.1
Thunderbolt Bus: MacBook Pro, Apple Inc., 41.1

It looks like the problem is an out-of-date macOS. Can you update to a more recent version of macOS?

1 Like

That fixed it! Thank you so much!

Great, glad to hear it!