RStudio does not install on Debian 10 or Ubuntu 19.04 (depends on old libssl)

root@dsg-laptop:/tmp# lsb_release -d
Description: Debian GNU/Linux buster/sid
root@dsg-laptop:/tmp# dpkg -l |grep libssl
ii libssl1.1:amd64 1.1.1a-1 amd64 Secure Sockets Layer toolkit - shared libraries
root@dsg-laptop:/tmp# dpkg -i rstudio-xenial-1.1.463-amd64.deb
Selecting previously unselected package rstudio.
(Reading database ... 344662 files and directories currently installed.)
Preparing to unpack rstudio-xenial-1.1.463-amd64.deb ...
Unpacking rstudio (1.1.463) ...
dpkg: dependency problems prevent configuration of rstudio:
rstudio depends on libssl1.0.0 | libssl1.0.2; however:
Package libssl1.0.0 is not installed.
Package libssl1.0.2 is not installed.

dpkg: error processing package rstudio (--install):
dependency problems - leaving unconfigured
Processing triggers for shared-mime-info (1.10-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.31.4-3) ...
Processing triggers for desktop-file-utils (0.23-4) ...
Processing triggers for mime-support (3.62) ...
Errors were encountered while processing:

It looks like you need to install libssl1.0.0 >=.

We support the Ubuntu LTS releases, e.g., 16.04 and 18.04, but not 17.04, 18.10, 19.04 (which is not released yet).

Debian 10 is a testing version, and I would expect support to be forthcoming in the 1.2 or later release, but defer to a member of the IDE team for the truth.


I think you might have more luck with the Debian 9 compatible release (it has stretch in the filename, not xenial). Can you try that one?


depends on libssl1.0.0 | libssl1.0.2

means depends on 1.0.0 or 1.0.2, not any greater version. Debian 10 and later has only 1.1.

0 jan@jan-buster:~/config/bundles$sudo apt install libssl1.0.2
[sudo] password for jan:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libssl1.0.2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl1.0.2' has no installation candidate
100 jan@jan-buster:~/config/bundles$

Yes I have running computer lab deployments with Debian 9 running the "xenial" version of RStudio.
I am reporting for the devs to know that the upcoming Debian/Ubuntu releases will not install that version.
They will be released in a few months (starting with Ubuntu 19.04 in April 2019).

I could not log in for the last 2 days to report it there (firefox or chrome).
chrome says: refused to connect.

My mistake. Sorry about that.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.