RStudio does not show .RData

I have installed the latest version of R and Rstudio on my PC but when I run the RStudio, it does not show any of my .RData. I know that they exist because I have RStudio on my laptop as well and I can see them there. But on my PC, nothing is shown. I have Windows 11 on this PC.

Files starting with a "." are hidden files, the "Files" panel doesn't show hidden files by default, you have to enable that option

Is that what you mean? if not, can you please clarify?

Thank you for your comment. I double-checked that and it was not the problem.
One thing that I noticed today is that even my laptop (with windows 10) does not show the .RData that was created on my PC (with windows 11). So I guess there are some discrepancies between .RData created by RStudio on windows 11 vs windows 10.

In RStudio, when I close it, a pop-up message asks if you want to save the data and I check yes, so it creates the .RData. and I can see it and use it again on that machine. Each machine (laptop or PC) only shows the .RData that was created on that machine. So I think that the antivirus or firewall setting is not blocking RStudio from creating .RData; the problem is that I cannot use the .RData created on one machine on another.

What you describe is a little confusing, are your files stored in a network drive or a cloud-synced folder? If it is a cloud-synced folder maybe that file extension is being ignored and that is why you don't see it on a different computer. Can you see the same .RData file in both computers using the Windows File Explorer?

They are stored on Box (something like Google Drive). It used to be fine when I had Windows 10 on both machine, but since I updated my PC to Windows 11, this issue came up.