Rstudio does not work even it is apparently installed on Mx Linux 21.1(32 bits)

Hi RStudio team,
recently came to my hands an old 32 bits lap top that is working on linux (Mx linux 21.1).
I am using R version 4.0.4 (2021-02-15) -- "Lost Library Book" on the terminal.

I tried to install rstudio v. 1.1.463 on it (because on RStudio website this version is the last recommended for 32 bits).I tried to install manually and on the terminal, it did not work, but...
now, some minutes before i send this message i tried to install it again, running a .deb package and terminal says there where some errors...and dependencies conflicts..
then using :
apt list --installed,
rstudio appears on the list and it appears at window where we select programs...but it does not run, nothing happens...

I send to you photos with info about my system and about the command used to install rstudio, as well as the list of installed programs where rstudio appears... Thanks for your time and help.
I will be looking forward to hearing from you.
P.D. Greetings from Mexico City.


Not a solution but an advice, trying to make a legacy version of rstudio to work on an unsupported operating system is going to be a nightmare if even possible.

I would be possible for you to change to a mainstream Linux distribution (e. g. Debian, Ubuntu, CentOS, etc)? This will make your life way easier in general, not just with R related things.

1 Like

Hi andresrcs , first of all, thanks for your reply and advice.
Given the system i have with 3gb of RAM and 32bits system i find difficult to change to a mainstream linux distro, maybe Debian 11 , AntiX, could be run...
Does anybody have similar problem as mine? (in 32 bits system)
please, let me know...

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.