rstudio doesn't start normally on ubuntu 18.04

Hi, I searched through the forum but didn't find the same issue.

I have followed these instructions for installation: Download RStudio Server for Debian & Ubuntu - RStudio
When i start rstudio I get the following:

This happens on nearly out of box Ubuntu 18.04.

Any help is appreciated!

let me check first of all.
do you intend to use Rstudio, or Rstudio Server.
These are two different products.

Thanks! I am looking to use rstudio

Then please see this list :slight_smile:

Thanks, that worked. Although rstudio must be run with admin permissions - what if a user without these wants to run it?

They should contact their admin

not very helpful... I am clearly talking about me running it as a regular user, without sudo. And my question is why should this be required.

I meant no offence, it wasn't clear that you were a desktop user acting as their own 'admin'. Many users of R are not. I have experience as an R user on windows desktop, as well as my companies hosted R server, on a commercial linux platform. As such I have an Admin (his name is Miles, and he's wonderful).

As I am not a desktop Linux user myself, I am not best placed to advise you how to configure your system for convenience in this regard, and will leave that to others. Best wishes to you.

Okay, fair enough. Thanks.

This is unusual.

Are you certain you have installed correctly both the RStudio Desktop for Ubuntu 18 and the R backend?

In Ubuntu this is done the easiest by installing package r-base-core but you would probably want a higher version than the 3.4.4 that is shipped with Bionic

Yes, I did install R 3.6 that way and still get that :confused:

That is a pity, because if you did not it would have helped to install R - a quick and easy win :slight_smile:

Just to double check that R is working correctly try running R in console - you should get a note about a Dark and Stormy Night; type q() to quit.

If R in console works as expected you will have confirmed that the issue is with RStudio. I would start with reinstalling (just in case) and if the easy way of the binary does not cut it than the long way of installing from source it must be...

Could you create and share a diagnostics report with us?

Also, one thing you might want to check -- does your user account have permissions to access the folder located at ~/.rstudio-desktop? Fixing permissions there may help:

sudo chown -R "$(whoami)" ~/.rstudio-desktop  # RStudio Desktop
sudo chown -R "$(whoami)" ~/.rstudio          # RStudio Server
1 Like

Hi Kevin,

thanks, yes, it was the permission of the .rstudio-desktop folder. It works as expected now.

Thanks!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.