RStudio encounters a fatal error and prompts to start new session

Hello Guys,
I was working an script and suddenly RStudio generated a fatal error and prompted to start new session.

I uninstalled and re-installed RStudio but the problem still remains. Attached below is the screen shot of the error.

The latest available R and RStudio versions are installed.

Following is the picture for the RStudio.Version

Are you working with a big dataset? This usually happens when you run out of RAM memory during code execution, check your memory allocation.

Dear @andresrcs,
You are correct, I just tried running another script that I have executed several times and has worked fine. it generated an error that said that "Unable to allocate memory."

screenshot of the same is below:

I did check my memory allocation as well, its at 50%. I was wondering when does one know that a given application is not getting enough memory it needs. As it can be seen in the picture that there is some that is not under use.

what I do not understand is that it does say that there is 7.9 GB available for allocation. Still it generates this error.

Can you guide regarding how to optimize this memory allocation problem?

Thanking you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.