Rstudio IDE - cant create directory or install packages

I havent used Rstudio in a few months. Logged in today, updated R Studio and then couldnt update any of the packages. I couldnt save any file to my documents folder either or create a new project! I logged out, restarted and tried logging back in as the Admin. Same Issue!

Any thoughts on what might be going on? Here are all the screenshots of my setup

It's tough to say, but it ultimately seems like some kind of permissions issue. It seems that the RStudio session is not being permitted to access files on your filesystem, including in your local R library and your temporary directory.

I’ve seen people reporting problems like this that seemed to be caused by Windows Defender Confrolled Folder Access, so you might try changing that setting to see if it makes a difference?


Thanks Kevin. I logged in as the guest account on my PC (Windows Guest has the least previlige) and surprisingly this account can install packages and read/write files. Both the Admin and User accounts somehow can not access the file system!
I uninstalled R and RStudio. Reinstalled everything. No impact. I rebooted and tried installing the previous version of R Studio. Still doesnt work.
Every other program - Microsoft Office, Sublime Text, NotePad, can all read and write files to the ~/Documents folder and any of the sub-folders.

This is just so weird. I know its got to be something really silly. Oh well. For the moment, I'm going to be using my Guest account for working with R.

Let me know if you have any other ideas for me to try out.

OMG - you are the best! That was it!
I knew it had to be something simple.

Thank you. Thank you!

1 Like

Glad you’re up and running again! It’s a little tricky because Controlled Folder Access operates separately from the usual permissions system, but the symptoms of the problem seem like a permissions thing. Apparently there’s supposed to be some sort of notification when Controlled Folded Access has blocked app activity, but it seems like either it’s not conspicuous enough or it doesn’t always fire. It would be nice if Windows Defender didn’t think RStudio-running-R looked suspicious! :sweat_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.