rstudio initialization error unable to connect to service


I have rstudio-server running on centos 7.3 , 1 user has an issue logging in ,the error is rstudio initialization error unable to connect to service , already tried to delete the users .Rstudio folder and delete his session files at /tmp , no process is running on the server of this user ,

any advise ?


Which version of RStudio server are you using? this might be applicable

To reset RStudio's state in version 1.3 and later:

The .rstudio , .config , and .local directories, as well as the .RData and .Rhistory files, are located in each user's default working directory (typically their home directory).

This means that you would also have to delete ~/.config/rstudio/ and ~/.local/share/rstudio/ for that particular user.


My server is rstudio pro , when this user is logging into another server with the rstudio free edition it works for him .

Also , I already tried to remove .Rdata , Rhistory .rstudio which are the only folders that exist from the ones one wrote that didn’t help .

Do you have any Idea what else could cause this issue ?

I meant the version number

If you are using version 1.3 or greater, try deleting this folders as I said before.

Do be aware that since this issue is connected to an RStudio Pro product, you are free to reach out to our premium support, by emailing
The product and support teams do check out #r-admin regularly, but they'll prioritize your support ticket.

my version is 1.2.5033-1 Professional (Orange Blossom) , any suggestion for actions to help in this regard ?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.