Rstudio installation on ubuntu

Hello, I am trying to install Rstudio on a ubuntu PC, the installation got nothing wrong but I got the following error while launching it in the terminal.

rstudio: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

The tricky thing is this PC is part of our cloud server so some libs may be configured by IT colleagues for all users. However, I have the root privilege for this local PC and only want to use it locally. Could anyone help to solve this issue? Thanks a lot.

sudo apt-get update
sudo apt install libssl1.0.0

is the first thing to try

1 Like

Thanks @technocrat. I tried and the installation was fine but still got the same error when launching rstudio. I guess I will wait for IT colleague back from vacation.

This usually just means you installed the wrong build of RStudio (e.g., you installed the build for Bionic but are actually on Xenial). What version of Ubuntu are you using?

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.