Rstudio keys conflicting with browser in Rstudio server

rstudioserver

#1

I use chrome or firefox, and some Rstudio hotkeys seems to have conflict with browser's

By instance, inserting a code section

Ctrl+Shift+R

forces browser to reload window!!

is there any way I can get same behaviour in Rstudio server than in Rstudio desktop?


#2

You can change the keyboard shortcut to one that works:

It is what I do on Firefox. The json file containing the customization can be saved for reuse.


#3

Maybe I did not make myself clear.
I want rstudio keys work the same as desktop. And the default combination (fresh clean install) I have been using for long time. Sometimes I work on desktop, sometimes on server, and Having different keys depending on where you are can drive you crazy in short time and I get used to default desktop keys.


#4

Yes I understood. It is the same for me and for keyboard shortcut that I use very often I do not use the default one. I change on both desktop and server to have the same.

I just wanted to share experience. I do not have a solution to make the default of desktop work on server where browser shortcut seems to take precedence. Maybe deactivate browser shorcut if possible ?


#5

modern browsers don't allow to change or disable keyboard shortcuts. :tired_face:


#6

Mozilla recommends an extension for changing Firefox's keyboard shortcuts — unfortunately I don't know of any reliable similar solution for Chrome. On a Mac, you can override any shortcut that appears in a menu via the system keyboard shortcut preferences.

Being forced to go against keyboarding muscle memory is so aggravating — like persistently having a stone in your shoe! :confounded: