RStudio mysteriously freezing

Hello all, I am posting here because I cannot find any answers to my problem.

About 2-3 days ago RStudio stopped being usable. Code runs in normal amounts of time, but the IDE itself is randomly freezing, sometimes for over a minute. The cursor in the editor is frozen completely, text doesn't appear when I type, and I cannot click on any buttons in the GUI. Sometimes it takes several minutes for RStudio to startup, and most of the screen is white. I have been using RStudio on this computer for the past 4 years without any issue. Base R works great, so I don't think it is an R issue itself.

Turning off my internet connection seems to make RStudio run normally again, which is surprising, but also problematic when you are trying to research, write, answer emails, etc.

I have tried deleting my entire R/RStudio installation and starting over with the newest version, but that made no difference. It makes no difference if I am using packages or not.

Anyone have any ideas that I can try?

For reference, I am using R 3.6.2, with RStudio 1.2.5033-1 on a Lenovo with Windows 7. As best as I can tell my OS hasn't updated recently enough to link it to this problem.

Thanks,
biometrician

This could be caused by a hang in display drivers. Does switching to software rendering solve the problem?

Hello,

I tried switching display drivers as described, but it did not help at all.

I also tried isolating R/RStudio from the internet with my firewall, but that also had no effect. However, turning off internet completely seems to work.

Thanks,
biometrician

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.