RStudio - not responding on Mojave

I newly upgraded my mac to Mojave. After the upgrade I opened Rstudio but it did not respond and freezed. Now every time I open it, it just crashes. It is written as not responding on the activity monitor. As soon as I start the program it goes to the top of the %CPU list with seemingly using 100% of CPU and it stays there. I run diagnostics but the log does not consist the events after the upgrade. I hope I can find the solution for this issue. Thanks!

The properties of my computer are:

Model Name:MacBook Pro

Model Identifier:MacBookPro14,2
Processor Name:Intel Core i7
Processor Speed:3,5 GHz
Number of Processors:1
Total Number of Cores:2
L2 Cache (per Core):256 KB
L3 Cache:4 MB
Memory:16 GB
Boot ROM Version:
SMC Version (system):2.44f1

Have you tried reinstalling RStudio? Also, what version of RStudio are you running?

Hi @mara,

Yes, I reinstalled Rstudio but nothing changed. Its version is 1.1.463.

OK. I think I solved the problem 10 min after posting :sweat_smile:. Sorry! I uninstalled Rstudio again, deleted all history files under ~/.rstudio-desktop and installed again. Now it works. I do not know the reason but at least solved it. Thanks!

1 Like

Yay! Glad to hear it's resolved. :tada:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.