RStudio Not Responsive in Big R File

Whenever I tried to edit Large R Files, I cannot even scroll and click at desired line, it was poorly slow like I have to wait like 1-2 minutes so that click move again to where I click.. I cant edit code properly, and I cant even click at the console area like its freezed.. Is there anything causing this?

(Note: this was fine when I am editing it in smaller R File like below 1K Codes )

I had to Disable Code Diagnostics from Global Options, I use Windows 7 Platform, and R 4.0.3.. But the problem still persists


Several months ago I had a similar experience. Unchecking 'include version control within RStudio' from the global options, git-tab, solved my problem.

Hope this gives a useful hint for you.


1 Like

Ah I see, Thankyou again for the advice, whats the purpose of enabling this anyway?

Files really of a 'high level', is there a standard measure a file called a high level? I would like to take a note one or two


Git is clear, so having the option to embed git-version control within Rstudio makes sense. However I have no idea what's going on behind the scenes. On my windows system (work, behind proxy) it brought performance back to normal. I operate git from the command line outside R. A home I'm on Linux system , and here I use Neovim as R's IDE., so I cannot tell whether it's a windows, proxy or Rstudio issue.

Anyway, glad it brought you back on track.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.