RStudio not working on Mac Mojave

Error Information:

RStudio is no longer working on my MacBook Pro (running OS 10.14). R itself works. RStudio launches but then fails to do anything more: I cannot open existing files, or open a new file. RStudio was previously working. I had not used it for a while, and it's possible that my OS has been updated since the last time it was working.

I have tried several troubleshooting steps suggested on the RStudio website:
• Deleting startup files (.RData, etc.)
• Verified that I have read and write permissions on RStudio and .rstudio-desktop
• I have done clean installs of RStudio three times with no success.

I was not able to verify the search path: typing the suggested command
into Terminal generates the error message
-bash: syntax error near unexpected token `"R"'

System Information:

From RStudio Desktop Will Not Start on

Usually when you update Mac OS you have to reinstall xquartz in order for rstudio to work

Thanks for the suggestion, but still no joy. A clean instal of XQuartz didn't fix the problem.

Do you have any better luck with the preview release?

I'm back in business! Thanks for the tip.

1 Like

Great! We are planning to prepare a full release of RStudio v1.2 very soon (what you see in the preview should be quite close to what we finally release) so please let us know if you find any issues.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.