Rstudio, notebooks and non standard engines


#1

Hello

Suppose I have registered another engine with knitr (and confirmed it works as expected using rmarkdown::render).
How can I get Rstudio to recognize it for their notebooks. E.g.


i dont get the ‘play’ buttons for that chunk to send to the R console.

Regards
Saptarshi


#2

Hi @sapsi,

For some reason whatever you put in after “E.g.” and before “i don’t…” isn’t showing up.

Was this an image or a snippet of code?


#3

@mara, you can check what someone actually posted with the q quote keyboard binding (likely getting to the post with j/k navigation keys), which will quote their original post (instead of how it ended up getting rendered, which the selection-quote does).

The code block should look like this:

```{myEngine}

```

@sapsi, you can include ``` in a code block by indenting the entire block by 4 spaces, similar to StackOverflow.

Unfortunately, I don’t actually have any information on how to solve the actual problem.


#4

Is this a setting inside of Discourse?


#5

You can see all of the keyboard shortcuts with ?. I don’t think there’s any settings involved, at least none that I recall enabling.


#6

What engine have you registered? One of the alternatives listed here? If the language is not R, then I wouldn’t expect you to be able to send code to the R console; if it is another interpreted language (e.g. some bash commands, or a Python code block) then you can send it to the Terminal that was introduced in the latest release, and you might be able to request a “Play” button to send those code chunks to the terminal, too.


#8

I have requested support for a “Run Chunk in Terminal” option via the play button: https://github.com/rstudio/rstudio/issues/1880

Please add a comment if you also like this and elaborate your use-case if needed.