RStudio on NAS regularly stalls for minutes and often terminates

I am running RStudio v.1.2.1335 Build 4 on our Debian 9 storage area network/server via a VNC viewer, and it is extremely unstable. I do not have an hour where I do not have to wait a good 5-10 minutes when the editing panel and console become unresponsive, menus expand and collapse but do not do anything more than that, and Rstudio very regularly terminates/aborts on me.

I would love to get Rstudio running more stably and faster but do not have an idea as to how to even start looking (how can I get rstudio to print diagnostics to the terminal from which it's launched or what other things can I do??). Neither can I say that a particular command is causing this.

Following this thread:

I have set "Show code completions" to "Manually (Tab)" (how do you do this when you launch rstudio??)

And when rstudio is behaving, the time to execute the suggested commands are (the first access to the path takes long presumably because the drive on the network has to be mounted):

Rstudio

system.time(list.dirs("path/with/lots/of/files"))
   user  system elapsed
  2.896  21.132 215.096 
system.time(list.files("path/with/lots/of/files"))
   user  system elapsed
      0       0       0 
system.time(list.dirs("path/with/lots/of/files"))
   user  system elapsed
0.404   3.108   4.662 
system.time(list.dirs("path/with/lots/of/files"))
   user  system elapsed
  0.444   3.164   4.761 
system.time(installed.packages())
   user  system elapsed
  0.004   0.000   0.030 

R in terminal

system.time(list.dirs("path/with/lots/of/files"))
   user  system elapsed
  2.000  20.516 191.224 
system.time(list.files("path/with/lots/of/files"))
   user  system elapsed
  0.000   0.000   0.001 
system.time(list.dirs("path/with/lots/of/files"))
   user  system elapsed
  0.568   2.996   4.736 
system.time(installed.packages())
   user  system elapsed
  0.008   0.000   0.033 

What else can I try to debug the problem?

Any help much appreciated,
Gina

You might also want to disable the project indexer. In Tools -> Project Options... -> Code Editing:

Try disabling [ ] Index source files (for code search/navigation).