RStudio requires quarto 0.9.80 - but not available...

I'm trying to experiment with quarto but can't get the the quarto install version to agree with RStudio.

When I launch RStudio with Preferences::Markdown::Quarto enabled/installed, I get this message in a yellow box at the bottom of the IDE: "Quarto CLI version 0.9.4 is installed, however RStudio requires version 0.9.80. Please update to the latest version at Redirect"

Clicking on that link leads me to Quarto - Get Started

I've installed Quarto CLI v 0.9.505 (Mac OS) from that page - which is the latest version available.

My version of RStudio is...
RStudio 2022.02.3+492 "Prairie Trillium" Release (1db809b8323ba0a87c148d16eb84efe39a8e7785, 2022-05-16) for macOS
Mozilla/5.0 (Macintosh; Intel Mac OS X 12_4_0) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.10 Chrome/69.0.3497.128 Safari/537.36

1 Like

Correct Quarto version is bundled within RStudio IDE and you shouldn't to have another version installed.

Which version is accessible from your PATH ?

quarto --version

in your OS terminal

To check the version that is actually found on your system.

If you type quarto --version in your RStudio terminal, what do you get also ?

That will help me understand your situation.

You could also try the last RStudio daily if you wish, maybe there was an issue in last release fixed since then.

MacOS:: quarto --version reports 0.9.4

RStudio Terminal::quarto --version reports 0.9.4

RStudio version reports:
RStudio 2022.02.3+492 "Prairie Trillium" Release (1db809b8323ba0a87c148d16eb84efe39a8e7785, 2022-05-16) for macOS
Mozilla/5.0 (Macintosh; Intel Mac OS X 12_4_0) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.10 Chrome/69.0.3497.128 Safari/537.36

I'm having a similar issue.
I was already using quarto before installing the latest Rstudio Desktop (v2022.02.3).
I now have the following warning message at the bottom of the rstudio window:

Quarto CLI version 0.9.58 is installed, however Rstudio requires version 0.9.80. Please update to the latest version at Redirect.

Current RStudio version:
"Prairie Trillium" Release (1db809b8, 2022-05-20) for Windows
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.8 Chrome/69.0.3497.128 Safari/537.36

What worked for me was

  1. I went to this page https://github.com/quarto-dev/quarto-cli/releases and downloaded the latest release as ZIP file. Probably for Mac it should be TAR.GZ

  2. Extract the contents to a folder named quarto containing the bin, share and other files.

  3. In the /<RStudioPath>/bin Installation, rename the existing quarto folder to quarto-original

  4. Replace it with the quarto folder just downloaded

  5. Inside the new quarto/bin folder, copy (not move!) all the files from the tools folder to the bin folder. (These include filename like pandoc, deno etc...)

This is needed to get the visual mode/editor working as RStudio relies on pandoc being in the quarto/bin folder but in the new Quarto builds they have put it in the quarto/bin/tools folder.

> Sys.getenv("RSTUDIO_PANDOC")
[1] "C:/rstudio/bin/quarto/bin"

Else activating the visual mode gets an error pop-up "Error: The system cannot find the file specified" for both Knitr and Jupyter Engines.

  1. Start or Restart RStudio and install the htmltools, rmarkdown and knitr
    packages

  2. Now File --> New -- Quarto Document

  3. I had selected Jupyter as the render engine which works and gives a preview inside RStudio itself.

Starting python3 kernel...Done

Executing 'quarto.ipynb'
  Cell 1/2...Done
  Cell 2/2...Done

pandoc 
  to: html
  output-file: quarto.html
  standalone: true
  section-divs: true
  html-math-method: mathjax
  wrap: none
  default-image-extension: png
  filters:
    - crossref
  
metadata
  document-css: false
  link-citations: true
  date-format: long
  lang: en
  title: Untitled
  editor: visual
  jupyter: python3
  
Output created: quarto.html

Watching files for changes
Browse at http://localhost:7374/
  1. Selecting Knitr as render engine also works.



processing file: quarto2.qmd
  |..............                                                        |  20%
  ordinary text without R code

  |............................                                          |  40%
label: unnamed-chunk-1
  |..........................................                            |  60%
  ordinary text without R code

  |........................................................              |  80%
label: unnamed-chunk-2 (with options) 
List of 1
 $ echo: logi FALSE

  |......................................................................| 100%
  ordinary text without R code


output file: quarto2.knit.md

pandoc 
  to: html
  output-file: quarto2.html
  standalone: true
  section-divs: true
  html-math-method: mathjax
  wrap: none
  default-image-extension: png
  filters:
    - crossref
  
metadata
  document-css: false
  link-citations: true
  date-format: long
  lang: en
  title: Untitled2
  editor: visual
  
Output created: quarto2.html

Watching files for changes
Browse at http://localhost:4749/

Hope this helps

@mnr This means that you have a quarto installed that is in your PATH, and which is version 0.9.4.
RStudio IDE will use the one in PATH first if one is found.

Can you find this installation ? which quarto should give you the where it is.
You need to remove it or update it.

@JBig same for you. Check which version you have found in your PATH with quarto --version in terminal.
Probably 0.9.58 and you need a more recent one.

@akvsak I would not tweak anything inside <RStudioPath>. You shouldn't need to do that to make it work.

If you have a quarto found in your PATH (which quarto on UNIX), then it will be used by RStudio IDE, even if an older version. Be sure to update the quarto installation you may have made in the past on your system.

I am willing to help sort this out so that we can update our docs. Please tell me all how that goes following the above advice to change the version found in PATH

1 Like

Got it. Yes, it is best used as a last-ditch attempt when everything else fails. :slightly_smiling_face:

Quarto is working for me now but anyway I ran these commands inside RStudio Terminal shell.

akvsak@homepc MINGW64 /c/Users/akvsak/Documents
$ quarto --version
bash: quarto: command not found

akvsak@homepc MINGW64 /c/Users/akvsak/Documents
$ which quarto
which: no quarto in ( <the standard Windows path variables> )

It seems to be that quarto bin is not found in PATH or within terminal inside RStudio. Maybe this is something improved within last versions of IDE. Using Quarto in RStudio IDE works though right ?

it confirms that you have no more quarto set in PATH. which is not an issue if you are using Quarto from RStudio IDE !

Here's what I did...

Macintosh Terminal:

mnr@Marks-MacBook-Pro ~ % which quarto
/usr/local/bin/quarto
mnr@Marks-MacBook-Pro ~ % cd /usr/local/bin
mnr@Marks-MacBook-Pro bin % ls -al quarto
lrwxr-xr-x  1 root  wheel  31 Jun  1 12:24 quarto -> /Applications/quarto/bin/quarto
mnr@Marks-MacBook-Pro bin % rm quarto
rm: quarto: Permission denied
mnr@Marks-MacBook-Pro bin % sudo rm quarto
Password:
mnr@Marks-MacBook-Pro bin % which quarto
quarto not found

When I open RStudio, it renders hello.qmd correctly.
The RStudio quarto preferences does not list any quarto version.

So - problem solved?
Thanks for your persistence...MNR

1 Like

Yes, I think you got back into a state where only the Quarto version bundled within RStudio IDE will be used.
So you let RStudio IDE manage quarto updates for you.

If you want to get a newer version at some point, you can install a new one from Quarto release, but in that case you need to manage update yourself following that, to avoid getting into the state you were in.

1 Like

Ducky.

I'm guessing the process described at Quarto - Get Started leads you into this situation - if you are using RStudio.

i.e.
Step 1 - install (the wrong version of) Quarto (at least the wrong version for RStudio)
Step 2 - install a version of RStudio that will complain about the version of Quarto you installed in step 1.

I suspect if you use VS Code, Jupyter, or a text editor the version of Quarto isn't a problem.

MNR

1 Like

Thanks! Problem seems to be solved.
I'm working with Windows 10.
I simply uninstalled quarto 0.9.58.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.