RStudio running slow and impeding work

My RStudio is running painfully slow to open, load, and execute even very simple tasks such as loading packages.

Things I have already tried:

Making sure the workspace is not being saved [Why Is RStudio so slow to start and to display data frames]

Uninstalling and reinstalling both R and RStudio

Resetting the desktop state [https://support.rstudio.com/hc/en-us/articles/200534577-Resetting-RStudio-Desktop-s-State]

Unchecking the diagnostics [RStudio running abnormally slow for every action, including cleaning console and saving file. - #8 by jd3365] but this did not make a difference

I am running the latest versions of both R and RStudio on a Windows 10 desktop. I work primarily using R projects if that is relevant. Though I don't appreciate any real improvement in speed if I try just running a simple script.

Any help appreciated. Thanks.

Are you on a network drive on a work computer?

Hi,

Any solution for opening the panes so slow?

Yes, I work in a university and am on a computer there. I made sure not to have any of my projects in a network drive because I have read that can complicate things.

It might be something to do with where packages are installed. I have had that issue with work computers where even though R is installed locally, the packages somehow get installed on the network drive.

Perhaps some sort of related info regarding the R_LIBS_USER file: R Installation and Administration

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.