RStudio says "You're using the newest version of RStudio", but I'm not


#1

When I click Help > Check for updates, I'm presented with the dialog "You're using the newest version of RStudio", yet when I click 'About RStudio', it says I'm using 1.1.423 whereas the newest version is (I believe) 1.1.447. Is this expected? Obviously not a huge concern, though I notice devtools::release() correctly identifies the version:

devtools::release()
* RStudio is out of date (1.1.423 vs 1.1.447)

#2

devtools::release uses the very latest version of RStudio from RStudio's website, whereas RStudio's Check for Updates is more conservative and won't tell you about a new release until it's been out for some time (and therefore been battle-tested).