Rstudio Server cannot connect to R session

I am using CentOS 8. My Rstudio-Server stopped working after a reboot. So I ran the following:

 sudo rstudio-server verify-installation

And it showed that "no version information available". I tried many things to fix it, including removing version 10 of postgressql, installing verison 13, and un-installing and re-installing rstudio-server.

It still shows the same problem:

usd1sapp101 opt]$ sudo rstudio-server verify-installation
/usr/lib/rstudio-server/bin/rserver: /usr/pgsql-13/lib/ no version information available (required by /usr/lib/rstudio-server/bin/rserver)
/usr/lib/rstudio-server/bin/rsession: /usr/pgsql-13/lib/ no version information available (required by /usr/lib/rstudio-server/bin/rsession)

I know postfres sql is installed properly via this command:

[bosr opt]$ psql --version
psql (PostgreSQL) 13.3

I used this link this link to configure postgres sql for rstudio-server.

What else can I try?

Also, why did the uninstall and re-install of rstudio server not fix the issue? If I wanted to uninstall rstudio server and start from scratch, what would be the best method? Thanks in advance.

Hey @rogerjbos! Can you share the output of yum list installed? Specifically those that are postgres related?

I haven't seen this issue before, but it looks like you may be missing a system library (like yum install postgresql-devel, perhaps?).

It surprises me that this issue would surface on a reboot though, unless an upgrade was included in the process recently. Have you recently upgraded RStudio Server Pro? What is the output of rstudio-server version?

If we don't make headway here quickly, it might be worth reaching out to our support team at and sending a diagnostic bundle to help us get a head start on the resolution!

Also, I'm not super optimistic that a complete reinstallation will help, since it may be related to a requirement on the newest version of the product.

I noticed that postgresql version 10.6 was the latest version on my app stream, so I removed version 13 and re-install 10.6. At you suggestion, I installed devel as well, so now here are the three that are installed:

postgresql.x86_64                                                           10.6-1.module_el8.0.0+15+f57f353b                                           @InstallMedia-AppStream                  
postgresql-server.x86_64                                                    10.6-1.module_el8.0.0+15+f57f353b                                           @InstallMedia-AppStream                  
postgresql-server-devel.x86_64                                              10.6-1.module_el8.0.0+15+f57f353b                                           @InstallMedia-AppStream                  

Checking the version still shows the missing information, but it does show version 10.6 as well:

[bosr rstudio]$ psql --version
psql: /lib64/ no version information available (required by psql)
psql: /lib64/ no version information available (required by psql)
psql (PostgreSQL) 10.6

I am using the open source version BTW, and my version is:

1.4.1717 (Juliet Rose) for CentOS 8

If I check the status of rstudio-server, it is running, but it still complains about the missing version information:

ā— rstudio-server.service - RStudio Server
   Loaded: loaded (/usr/lib/systemd/system/rstudio-server.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2021-06-22 14:13:39 EDT; 8min ago
  Process: 108234 ExecStop=/usr/bin/killall -TERM rserver (code=exited, status=0/SUCCESS)
  Process: 108236 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=0/SUCCESS)
 Main PID: 108237 (rserver)
    Tasks: 3 (limit: 49630)
   Memory: 8.8M
   CGroup: /system.slice/rstudio-server.service
           ā””ā”€108237 /usr/lib/rstudio-server/bin/rserver

Jun 22 14:13:39 systemd[1]: Starting RStudio Server...
Jun 22 14:13:39 rserver[108236]: /usr/lib/rstudio-server/bin/rserver: /lib64/ no version information available (required by /usr/lib/rstudio-server>
Jun 22 14:13:39 systemd[1]: Started RStudio Server.

and of course I still get the error message "Could not connect to the rsession on Rstudio server."

BTW, run-diagnostics does not seem to work for the open-source version and is not listed as one of the available commands:

[bosr rstudio]$ sudo rstudio-server run-diagnostics
Usage: rstudio-server {status|start|stop|restart|test-config|verify-installation|suspend-session|suspend-all|force-suspend-session|force-suspend-all|kill-session|kill-all|offline|online|active-sessions|version}

Ohh sorry about that! I missed that you were using the open source version :see_no_evil: This is definitely the right place to be asking then!! :grinning_face_with_smiling_eyes:

It does look like some type of sysdep issue. I am not super familiar with the centos8 package names, but it looks like libpq is the one that RStudio needs, and is the one that is having trouble in your system.

On a docker container I just started:

[root@90e8d9b8b2fa /]# yum list installed | grep pq
Failed to set locale, defaulting to C.UTF-8
libpq.x86_64                      13.3-1.el8_4                        @appstream
[root@90e8d9b8b2fa /]# find / -name

It may be worth starting a new shell / checking your LD_LIBRARY_PATH to see what is getting picked up? You could also look at the /lib64/ file - it looks like something weird is going on with it.

I removed libpq and re-installed it and here are the two folders where the file is located:

bosr lib64]$ ls -l /usr/lib64/libpq*
lrwxrwxrwx. 1 root root      13 May 13 10:19 /usr/lib64/ ->
lrwxrwxrwx. 1 root root      13 May 13 10:19 /usr/lib64/ ->
-rwxr-xr-x. 1 root root 1380680 May 13 10:19 /usr/lib64/
[bosr lib64]$ ls -l /lib64/libpq*
lrwxrwxrwx. 1 root root      13 May 13 10:19 /lib64/ ->
lrwxrwxrwx. 1 root root      13 May 13 10:19 /lib64/ ->
-rwxr-xr-x. 1 root root 1380680 May 13 10:19 /lib64/

I don't know if it is a binary file, but I cannot really open it to look at it. It has mostly characters that cannot be displayed.

Oops! Totally missed this message, sorry about that!

Maybe a better path is to ldd the rstudio-server binary to see what it is linked against?

# ldd /usr/lib/rstudio-server/bin/rserver (0x00007ffe1c34d000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde09aec000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde098a3000) => /lib/x86_64-linux-gnu/ (0x00007fde0969f000) => /lib/x86_64-linux-gnu/ (0x00007fde09480000) => /lib/x86_64-linux-gnu/ (0x00007fde0927d000) => /lib/x86_64-linux-gnu/ (0x00007fde09076000) => /lib/x86_64-linux-gnu/ (0x00007fde08e6e000) => /lib/x86_64-linux-gnu/ (0x00007fde08c51000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde089c4000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde084f9000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde08170000) => /lib/x86_64-linux-gnu/ (0x00007fde07dd2000) => /lib/x86_64-linux-gnu/ (0x00007fde07bba000) => /lib/x86_64-linux-gnu/ (0x00007fde077c9000)
	/lib64/ (0x00007fde0a7f4000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde0757e000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde0732c000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde07056000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde06e24000) => /lib/x86_64-linux-gnu/ (0x00007fde06c20000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde06a15000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde06807000) => /lib/x86_64-linux-gnu/ (0x00007fde065ec000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde063d1000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde06190000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde05e2a000) => /lib/x86_64-linux-gnu/ (0x00007fde05c26000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde05a1d000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde05790000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde054ee000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde052b8000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde050a2000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde04d73000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde04b56000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde047d8000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde045c5000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde0438f000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde04159000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde03ed8000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde03caf000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde03aa0000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde03856000) => /lib/x86_64-linux-gnu/ (0x00007fde0361e000) => /usr/lib/x86_64-linux-gnu/ (0x00007fde03416000)

@cole, just thought I would let you know that my problem was resolved by disabling selinux, which I learned about in this post: rserver[1692]: ERROR system error 13 (Permission denied) - #10 by ArchosaurRise

Thanks again for your help. Roger

1 Like

Glad to hear!! Well done resolving, and thanks for coming back here to share!!

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Hereā€™s how to do it:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.