Rstudio-server couldn't start from browser

rstudioserver

#1

I have installed rstudio server on my linux Debian server,

sudo rstudio-server status

● rstudio-server.service - RStudio Server
Loaded: loaded (/etc/systemd/system/rstudio-server.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2019-01-05 17:03:09 CST; 2min 3s ago
Process: 18279 ExecStop=/usr/bin/killall -TERM rserver (code=exited, status=0/SUCCESS)
Process: 18289 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=0/SUCCESS)
Main PID: 6287 (code=killed, signal=TERM)
Tasks: 3 (limit: 4915)
CGroup: /system.slice/rstudio-server.service
└─18290 /usr/lib/rstudio-server/bin/rserver

I tried to open rstudio server in my linux through http://localhost:8787/, it works,

But when I tried through my PC's browser through 47.75.49.118:8787, if failed:

Could you anyone give some suggestions?

I've tried:

sudo rstudio-server restart

but return nothing and didn't work.

When input

sudo netstat -anp | grep 8787

it returns,

> tcp 0 0 0.0.0.0:8787 0.0.0.0:* LISTEN 19089/rserver

thanks


#2

Is your server on the same local network than your PC? Do you have a fiscal server or a virtual one? If your server is on a different network, do you have port forwarding configured in that network? Or if you have a virtual server, do you have that port open?


#3

Thanks for your reply.

It is on a fiscal server. Actually, today I found that other computers in my company can access to this ip-addresss:8787 rstudio, but my computer can't. Moreover, my computer can access to it several days ago. The connection suddenly failed. I don't know where is the problem.


#4

Hard to know without any more information, I think it's more a networking problem than a rstudio-server one