`Rstudio` Server in `Docker` container: Can't access locally mapped 8787 port (Byzantine Infrastructure)

Hi,

I'm trying to get the following to run:

  1. In a QubesOS Xen VM running Fedora 31, I'm
  2. using podman to run a rootless docker.io/rocker/tidyverse container as follows:
podman run -d -p 127.0.0.1:8787:8787 -v /tmp:/tmp -e ROOT=TRUE -e DISABLE_AUTH=TRUE docker.io/rocker/tidyverse

From the podman host I can test the setup using curl like so:

curl -I --user-agent 'GoogleChrome' http://localhost:8787

with the following result:

HTTP/1.1 200 OK
X-Frame-Options: DENY
Expires: Fri, 01 Jan 1990 00:00:00 GMT
Pragma: no-cache
Cache-Control: no-cache, no-store, max-age=0, must-revalidate
Content-Type: text/html
Content-Length: 1339
Date: Wed, 09 Sep 2020 22:38:46 GMT
Connection: close
X-Content-Type-Options: nosniff
Server: RStudio

That looks OKish, no?

When I try however (again in the podman hosting Xen VM) to access localhost:8787 using a browser (tried firefox and chromium), the tab shows the appropriate RStudio label, yet the loading-indicating applet spins endlessly to be replaced by a message stating that R takes longer than usual to load, accompagnied by buttons for reloading, starting in safe mode and restarting the R session (none of which make any difference).

Does anyone have an inkling why I might be unable to browse to the RStudio Server installation? Is this a case of browser incompatibility fixable by using Google Chrome proper (or adjusting the user agent string (to what?))?

Thanks for any hints.

Sincerely, balin

I have tried the slightly simpler

docker run -d -p 127.0.0.1:8787:8787 -v /tmp:/tmp -e ROOT=TRUE -e DISABLE_AUTH=TRUE docker.io/rocker/rstudio

on my local Linux laptop, which works without problem. Maybe try to simplify your your use case to pinpoint the problem?

Thanks for your input - I have meanwhile gotten to the bottom of this (see here): surprisingly, the issue I'm encountering has nothing to do with the byzantine setup I choose, but with RStudio currently being afflicted by a bug with respect to the DISABLE_AUTH=TRUE environmental variable handling ... so when I use

podman run -d -p 127.0.0.1:8787:8787 -v /tmp:/tmp -e ROOT=TRUE -e PASSWORD=test docker.io/rocker/tidyverse

instead, all works out nicely. I'm eagerly awaiting the fix of this issue showing up in the docker.io/rocker-provided images ...

Interesting! So it worked for me because I had the necessary cookie present, since I do a lot of tests with RStudio Server running on localhost.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.