RStudio Server Open-Source not working

Hi there - I just installed R 4.21 on a CentOS 7 system and then installed RStudio Server. I was logged in remotely with the root user via putty. I followed these instructions and there didn't seem to be any issues:

But I cannot access RStudio via a browser at http://:8787. I just get a "site can't be reached" error in chrome. When I try to verify the installation I get:
TTY detected. Printing informational message about logging configuration. Logging configuration loaded from '/etc/rstudio/logging.conf'. Logging to '/var/log/rstudio/rstudio-server/rserver.log'

However there's nothing in that folder. I used RStudio Server a lot on a different machine, but I've never dealt with admin or installation. It seems like the server is running when I check status, and the rserver.conf file is empty (default?). R is working fine.

Any help would be greatly appreciated!


I've tinkered with rserver.conf to change the port (e.g. 80):

and to specify the path:

Restarted server each time. No luck, and still get "TTY detected" message with each start.

Are you sure that port is open in your server? If port 80 is open you can use Nginx to reverse proxy to that port

Looks like the port is open. I've checked 2 ways (though I should note that I'm pretty new to all things linux):

sudo netstat -tulpn | grep LISTEN returns (among others):
tcp 0 0* LISTEN 167298/rserver

sudo lsof -i:8787 returns:
rserver 167298 rstudio-server 7u IPv4 1852143 0t0 TCP *:msgsrvr (LISTEN)

I'm also able to successfully change the port in rserver.conf and see it reflected in the commands above. But still can't connect.

Was wondering if it might be on the client end, but when I disable my vpn (required to access the server) I get DNS_PROBE_FINISHED_NXDOMAIN instead of ERR_CONNECTION_TIMED_OUT when the vpn is on.

I think it's firewall / port related. After trying firewall-cmd --add-port 8787/tcp I get ERR_CONNECTION_REFUSED in my browser instead of ERR_CONNECTION_TIMED_OUT. Seems like progress!

I'm in! I had to restart rstudio-server after allowing the port the firewall.

1 Like

I'm glad you solved your problem, sorry for not giving specific commands to open the ports but I'm a Ubuntu Server person, I don't have experience with RHEL based Linux distros

You sent me off on the right track - thanks!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.