RStudio Server Ubuntu 20.04

Hi all,

I am trying to install RStudio Server on my newly installed Ubuntu 20.04 machine, but I am running into issues.
I managed to install R version 3.6.3, as well as RStudio Desktop, both 1.4.294-amd64, (nightly release) and 1.2.5042-amd64 (stable).

When trying to install RStudio Server, using either versions :
- sudo gdebi rstudio-server-1.4.294-amd64.deb
- sudo gdebi rstudio-server-1.2.5042-amd64.deb

I am running in the following error:
Process: 4313 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=127)
or sometimes
Process: 5601 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=127)
mai 02 15:09:33 Mortimer systemd[1]: rstudio-server.service: Control proces…/n/a
mai 02 15:09:33 Mortimer systemd[1]: rstudio-server.service: Failed with re…de'.
mai 02 15:09:33 Mortimer systemd[1]: Failed to start RStudio Server.

I couldn't find any information on the internet regarding this error.
Has anyone managed to get RStudio Server working on an Ubuntu 20.04 machine ?
Or has anyone ever encountered such an issue and could help me ?
I am quite new to RStudio Server and Linux. I am trying to set up a spare computer as a Linux based RStudio Server to help me with my projects as I am working from many different places and computers.

Best regards,

Mortimer

Unfortunately Ubuntu 20.04 is not yet on the supported platform list.

Can you try the installation on Ubuntu 18.04 instead?

Maybe I'm just lucky, but I have RStudio Server 1.3.947 running on Ubuntu 20.04, and so far no problems. I started with the "server" install of Ubuntu, not desktop, so I don't know if that has anything to do with it. I also used apt to install, and made sure that I had the prerequisite R packages and any dependencies beforehand.

I also cannot install RStudio Server 1.2.5042 doesn't install on my WSL Ubuntu 20.04; seems it is not compatible. But I get a different error:

/usr/lib/rstudio-server/bin/rserver: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

I have installed the latest version of libssl-dev and libssl1.0.0 is unavailable with the following error:

Package libssl1.0.0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

It seems RStudio Server 1.3.947 is a professional version not available to the general public (or am I wrong? I can't find a download link, only a user manual that doesn't contain installation instructions for rstudio server itself). I use RStudio Server to run RStudio in my WSL (which doesn't have a GUI - so I run RStudio in my browser). Is there any other solution for me until Ubuntu 20.04 is supported? Thanks!

RStudio v1.3 has not yet been released, but preview releases are available here:

Hi I have installed rstudio-server pro on lubunutu 20.04. I had no issues during install but i cannot login to the actual webinterface. Whenever I enter my username and pw it does not login. If I enter the correct username and pw it just reloads the login page, if I enter a wrong username or wrong password i get the usual notification that username and/or pw are wrong.

pamtester does not show any issues.

So rstudio server recognizes the login credentials, but does not forward to the actual interface.

The same happens when i want to get to the admin page ip-address:8787/admin

Any ideas?

I solved the issue. It was a missing Java installation on the server.

had issues getting rstudio-server running on fresh install of 20.04 -- installing depreciated libssl1.0.0 package from prev. version of ubuntu got it working for me.

http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb