RStudio slow response over VPN

rstudio
performance

#1

I've been using RStudio quite a while. Recently, I've noticed that when I am logged into my company's VPN (to access secure data), execution of even simple functions with RStudio slows to a crawl. However, loading up base R while on the same VPN connection is as fast as I would expect.

Are there some RStudio settings that should be tuned for working over VPN? Or is this a bug?

I've seen this issue mentioned various times over on the Pro Support site but any resolution is unclear:

Thank for any comments or suggestions you can provide.


#2

What version of RStudio are you using? There were some reports of such slowness that we believe should be resolved in the latest release of RStudio (v1.1.442).

If that doesn't solve the issue, a diagnostics report may be helpful.


#3

Thanks for the response. I am using v1.1.423. Will update now and try it out, reporting back the results and/or diagnostic report.


#4

I've using v1.1.442 today over VPN and noticed some improvement but continue to see significant lag between execution of commands and return of results. For example:

list.vars.m<-c(...) # 74 string elements
list.vars<-c(...) # 62 string elements
system.time(print(intersect(list.vars.m,list.vars)))
...
user system elapsed
0.04 0.03 3.30

I have generated a diagnostics report and can send over if you let me know how to provide it.


#5

You might try uploading it as a Gist and sharing a link.

Can you also try entering Ctrl + ` and send a screenshot of what you see there, immediately after executing a command that takes longer than expected? (This should show a request log of commands run by RStudio; that might help us further narrow down what could be going on)


#6

Screenshot included. And here is a link to the gist: link