Rstudio spanish spell check doesn't seem to work with special characters


I set Spanish as the main dictionary for spell checking; It seems to work, but the options that are given by the IDE when something is spelled wrong seem to be lackluster, and in general, they don't seem to include words with special characters such as "ñ" or acentos ("á", "é", "í", "ó"). I am writing a Rmarkdown document, and I m using the RStudio v1.4 (the preview version with visual Rmarkdown, which I wasn't using when this issue came up).

For example, if I write "espanol", which should be corrected to "español" (Spanish), the IDE won't suggest that as an option for correction, even for this very simple mistake. The same thing happens for "arbol", which should be corrected to "árbol" (tree).

This doesn't seem to be an issue with the dictionary file because I looked at it and it does include words with those characters.

Is there any way to fix this?

Thanks in advance

Note: I tried to find another post with the same issue, but couldn't find any. Sorry if this has already been brought up before

I can reproduce this problem. This seems like a bug to me so I think it would be better if you formally file an issue report on the GitHub repo.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.