Rstudio start-up system error 2

Hi,

I have a problem with R studio start-up I haven't come across any previous posts with the same issue. When trying to start-up R studio, I get an error message (see attached photo) saying that the "SessionConsole.R" file is missing. I've checked the folder and this file is indeed missing, but I'm not sure how as it has been working just fine. Can anyone suggest a way of fixing this, as I'm unable to load Rstudio currently?

I would like to avoid uninstalling and reinstalling Rstudio if possible as I'm working on a work computer for which I don't have an admin password for installing new programs.

Many thanks,
G

2 Likes

I have the exact same issue. I just got back from a two-week holiday and my work computer performed some updates when I restarted it, I assume that's related.

(post deleted by author)

Hi Oliver,

I found out what was causing the problem, in my case anyway:

RStudio had been updated to the latest version, but R itself was still running on an older version which must not have been compatible with the updated RStudio. Try updating R itself in RGui to see if that fixes the issue. I wasn't able to update R as the version was too old for the "installr" function, so I had to download the latest version off the internet. Then, when starting up RStudio, press and hold Ctrl as you click the RStudio icon and a window will pop up where you can select which version of R you want to run.

Hope this helps

Hmm very weird, seems like my problem was the opposite. It gives me the error with the newest R versions (4.2.1 and 4.2.0), but it's fine when I fall back to 4.1.3.

Thanks for the Ctrl-click tip though, at least something works now.

Has anyone been able to find an alternative solution to this? I have tried on both R 4.2.1 and 4.1.3, and the issue seems to be within RStudio instead. I have tried both RStudio 2022.07.0-548 and 2022.07.01-554 and the issue still persists.

The fact that the above solution worked for me, and that something similar worked for Oliver, suggests it is something to do with the versions of RStudio and R not being compatible, but I'm not 100% sure.

Are you getting the same error message, Guy?

Yep, exactly the same. I have downloaded an older version of RStudio (2022.02.3 Build 492), and this seems to have stopped the issue with R 4.2.1