RStudio stuck loading Push to Git

Help, please. I'm new to both RStudio & Github and I'm having a problem with Rstudio getting stuck pushing to GitHub

I have connected Github and Rstudio with the SSH key.
I went through the steps of creating a repository in Github and then creating a new project in RStudio linking it to the repo.

I can pull fine from Git into RStudio but anytime I try to push anything back it gets stuck on the loading/processing pop up screen. No error messages or failure but just never stops loading/processing.
I'm currently trying to push a text file saved as

I've tried search for help on the topic but the only thing I could find was the same issue occurring back in 2018 that was resolved with a later release.
I currently have version 1.4.1717 installed.

Would greatly appreciate help!

I am using RStudio ver 4.1.0 on Ubuntu 20.04 LTS and are having almost exactly the same issue.

Previously (24 days ago), I was able to PUSH & PULL correctly usin RStudio and Github with SSH_Keys. The only variable that has changed is the changeover at Github from PASSWDs to SSH_Keys. Could this be related?

Although I am getting a specific SSH message:

>>> /usr/bin/git push origin HEAD:refs/heads/main
ssh: connect to host port 7913: Connection timed out
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I have no idea why the SSH would be attempting to connect to Github Port 7913. However I do use Port 7913 on all of my sshd_configs, for both this machine and remote Debian-based ones. Coincidence?

In the meantime, I am going to revoke all SSH_Keys, Passwds and Personal Access Tokens, then start again.

This issue has now been solved.


  • Remove the existing SSH_Keys in the Github account
  • Remove the existing SSH_Keys from ~/.ssh
  • Generate new SSH_Keys using RStudio > Tools > Global Options > Git/SVN
  • Export new SSH_Key to Github using xclip
  • Create new file touch ~/.ssh/config
  • Edit file nano ~/.ssh/config
  Port 443
  • Test using ssh -T
  • Commit & PUSH as per spec

If anyone would like further details on the exact process and commands, please let me know and I can edit this post with the full commands.

I am unable to ascertain what exactly broke in my system SSH, which is always an issue.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.