Rstudio v1.1.463 rpubs upload error, no login prompt - RStudio IDE


#1

I am having trouble publishing to RPubs and am getting the following error message:

Error in if (result$status == 201) succeeded <- TRUE : missing value where TRUE/FALSE needed Calls: <Anonymous> In addition: Warning message: In http(protocol, "api.rpubs.com", port, method, path, headers, : NAs introduced by coercion Execution haltedPreformatted text

I know this was previously discussed in the following: Rstudio v1.1.456 rpubs upload error, no login prompt

But I don't know how to implement the fix. Can someone please help me with each step.

I am completely new to R.


#2

If you don't have the package devtools already installed, first install it with

install.packages("devtools")

Then you can install the development version of rsconnect package with

devtools::install_github("rstudio/rsconnect")

And that should solve your problem.


#3

Thank you very much for your reply, that was very helpful!

I installed the devtools package but when I try to install the development version of rsconnect I get the following error message:

Error in curl::curl_fetch_memory(url, handle = h) :
schannel: failed to receive handshake, SSL/TLS connection failed

Any other ideas?
Thanks.


#4

Restart R session (Ctrl + Shift + F10) then install this

install.packages(c("curl", "httr"))

then try again with

devtools::install_github("rstudio/rsconnect")

#5

Thank you very much. When installing "curl" and "httr" I got the following:

package ‘curl’ successfully unpacked and MD5 sums checked
package ‘httr’ successfully unpacked and MD5 sums checked

I tried again with devtools::install_github("rstudio/rsconnect") but still got the following:
Error in curl::curl_fetch_memory(url, handle = h) :
schannel: failed to receive handshake, SSL/TLS connection failed'

I restarted R session to see if that would change anything but I am still getting the error message.


#6

I think this is a problem specific to your system.

Is your connection behind a proxy server? Do you have git installed in your system?


#7

I think you are right. Yes, my connection is behind a proxy server (Working off of my work PC) and no I don't have git installed. I will try from another PC. Thanks for your help!


#8

You can set your proxy settings with httr package.

library(httr)
set_config(
  use_proxy(url="your.proxy.ip", port="port", username="user",password="password")
)
devtools::install_github("rstudio/rsconnect")

#9

It works!! Thank you very much for all of your help! I appreciate your time.


#10