RStudio v1.2 has problem with DPI in high resolution monitor

rstudio
ide-bug
hidpi-monitor

#1

I installed the newest version of RStudio (i.e. v1.2.679-1 Preview) and the fonts and the whole application is so large that is almost impossible to work. My 27" monitor has res. 3840x2160. Is it known problem? I tried to fix it using scaling DPI by system but results do not satisfy me. Previous ver. RStudio works well. I know that something can be change in settings (Appearance) but it's not good solution.


#2

What happens when you adjust RStudio's menu font sizes with ctrl+"+" and ctrl+"-".
Or adjust adjust the size of console, code and other window fonts via tools >> Global Options >> Appearance?


#3

In Windows zoom in: CTRL+Shift '+' ; zoom out: CTRL '-'
That works: fonts and tabs change the size. But the question is: why in all of the previous versions of RStudio I didn't have to do? Thanks, but I uninstall RStudio from my PC because it's impossible to work with (I checked on my laptop.).


#4

I ran into the same thing today, but could zoom it down to 75%. I like the more native look so far. There are still some quirks. For example, the git management window is still super big. And there's a weird white square in the packages pane.

Windows 10, Version 1.2.679 – Build 703 (415a39c1)

Edit: I think the shocking largeness happens because Windows 10 can upscale everything to be 150% size on high DPI screen.


#5

There is a problem with RStudio not with Windows 10. Previous versions works well.


#6

I just meant it’s the interplay of the two.


#7

@RobertForum: Are you using just a single monitor with a resolution of 3840 x 2160, or do you by any chance have a dual-monitor setup? (Just in case it's multiple monitors + multiple resolutions triggering the bug in RStudio)

It would be helpful if you could confirm which version of Windows you have installed, as well.


#8

I use only a single monitor. I use Windows 10 Education x64, build 1803.
Thanks for the response.


#9

I'm having a similar problem, having recently moved to a dual monitor setup wit ha WIndows laptop. The laptop screen is a 3000x2000 13" screen, so very high DPI, and the monitor is a larger but only a 1920x0180 screen. I can adjust the zoom in RStudio for either monitor, but I'm not sure if there's some sort of adaptive solution I'm missing.

(Windows 10 Pro 1803)

EDIT: ref. also this thread and this comment. I can see this has been issue for a while and that you're well aware of it :slight_smile:

I'm finding that the ideal zoom for RStudio in my setup matches that for Windows: 100% for both RStudio and Windows on my external monitor, and 175% for both RStudio and WIndows on my laptop display. Perhaps a future version of RStudio could have an option to read the current display's zoom setting on boot and on changing displays? (I don't have much Windows dev experience; I shouldn't presume :stuck_out_tongue_winking_eye:)


#10

I am using a high resolution XPS 15 and I believe the RStudio is matching the Windows scaling set for that laptop screen (150%) and not the scaling I set for my external monitor (100%). It is frustrating because I essentially cannot use my RStudio on my external monitor. Similar problem here:

Hope this can be fixed soon.


#11

What version of Windows are you using, and what version of RStudio? With the latest daily builds, in my two monitor Windows configuration (one at 150%, other at 300%) the IDE transitions appropriately based on which monitor the IDE window is being displayed on. That is, when I drag the IDE window from one monitor to the other, the IDE window resizes and UI elements are rescaled as appropriate for the monitor RStudio is showing on.

This is with a desktop machine running Windows 10 Pro 10.0.1734, with two Dell P2415Q monitors (both at 3840 x 2160 resolution). The re-scaling appears to work fine regardless of what Windows scaling I set, or how I change or modify the monitor resolution.