Rstudio warning "unable to establish connection.."

Hi, there!
This message "Error: Unable to establish connection with R session" has been popping up for everything I try to do on Rstudio since yesterday. I have to run the code a bunch of times for it to work. It even pops up while some function is working and stops it.
This is my session info:

R version 4.0.2 (2020-06-22)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 18362)

Matrix products: default

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_4.0.2 tools_4.0.2

Rstudio was working fine until then. The trigger I think it was opening a downloaded database. I've tried everything. Uninstalling R and Rstudio (and deleting all the folders, even Rstudio-desktop), installing and older version of Rstudio... Also, the "restore .Rdata into workspace at startup" option is disabled. My antivirus is Windows defender.

Update: I had to install Rstudio version 1.1.463 for the message to disappear. My problem is with Rstudio 1.3.056 and Rstudio 1.2.5042

Hope anyone can help me, I need to work and this is such a pain!
Thank you in advance,

Hi, I had the same error today which dissappeared after I removed some software I just before had installed. (Not sure which of them caused it though). Hope it helps, Cheers, Wim

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.