Scrolling past code


#1

I currently feel a bit frustrated as I cannot scroll past my written code, but I prefer to have the code on eye level.
Is there somewhere an option to change it? I looked through the Global Options, but coudln’t find anything. Did I miss it or would that be a future feature?


#2

Does tools > Global Options > Code > Display and then check the ‘Allow scroll past end of document’ box do what you are after?


#3

Thanks, I don’t seem to have that option. For some reason it only shows Diagnostics. Will check my installation.
Edted: Downloaded RStudio again. I presume that Display is another section of that box. I cannot even see the Snippets content. I also cannot resize that Options box.
00

My specs are:
Model Name: iMac
Model Identifier: iMac14,1
Processor Name: Intel Core i5
Processor Speed: 2.7 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 8 GB
Boot ROM Version: IM141.0118.B47
SMC Version (system): 2.14f24
Serial Number (system): C02LF0JEF8J2
Hardware UUID: ABF06444-3A55-55B6-B85E-37D00B900FDB


#4

Ah OK yeah that menu looks different to mine (see image) possibly a bug on mac OS?

I am using Rstudio:Version 1.0.153 on Windows 10. Sorry don’t think I can be much help.


#5

Latest RStudio on macOS Sierra here, I have that setting and have been using it for quite some time now, so I’m confident it is there, and it works.

Maybe try a different RStudio version (preview or dailies), or try changing your screen resolution, as window sizing seems to be an issue.
Annoyingly that options window can’t be resized in general AFAICT, so that’s not specific to your issue (even though mildly infuriating).
Your hardware UUID is also probably less important than your macOS version, so I can only give you general “make sure all your stuff is up to date”-advice, sorry :confused:


#6

The screenshot suggests that you’re on an older version of MacOS. Do you know what version that is? RStudio uses a MacOS system component to render its UI.


#7

Thanks, I’ll have to check when I am back at work. True, on my home laptop (Ubuntu) it actually works fine. I’ll try and play around with the Mac Versions to see whether it makes a difference.