Section numbering in bookdown

Hi,
Is there a way to stop numbering the section when I write a bookdown ("number_sections: no"). If so, where should I place it in the yaml?
Currently my setup is the following:

yaml at index.Rmd:

title: "A születési mutatók alakulása és az azt kísérő változások Magyarországon" 
author: "Granát Marcell"
output: bookdown::gitbook
site: bookdown::bookdown_site
favicon: "logo.ico"

_bookdown.yaml:

book_filename: "my-book.Rmd"
language:
  ui:
    edit: "Jump to GitHub"
  label:
    fig: "Ábra "
    tab: "Táblázat "
edit: https://github.com/MarcellGranat/ujdemografiaiprogram/master/%s
output_dir: "docs"
sharing:
  github: yes
  facebook: yes
  twitter: yes
  all: no
rmd_files: ["index.Rmd", "Chapter-1.Rmd", "Chapter-2.Rmd", "Chapter-3.Rmd"]

_output.yaml:

bookdown::gitbook:
  config:
    number_sections: no
    toc:
      collapse: section
      before: |
        <img src="logo.png" width="300" height="300">
    sharing:
      github: yes
      facebook: yes
      twitter: yes
      all: no

You correctly need to put that under the format in bookdown::gitbook inside _output.yaml. But number_sections is a parameter for bookdown::gitbook directly. See the help page ?bookdown::gitbook()
So you need to not put it in config but one level below bookdown::gitbook

bookdown::gitbook:
  number_sections: false
  config:
    toc:
      collapse: section
      before: |
        <img src="logo.png" width="300" height="300">
    sharing:
      github: yes
      facebook: yes
      twitter: yes
      all: no
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.