Selectively enable subpixel antialiasing on macOS Catalina

After upgrading to macOS Catalina 10.15.2, system fonts on my external 1920x1080 monitor looks best with font smoothing turned off:

defaults write -g CGFontRenderingFontSmoothingDisabled -bool YES

However, this has the side effect of causing RStudio preview version 1.2.5034 fonts to appear very narrow. Is it possible to selectively enable subpixel antialiasing for RStudio? I tried the following two commands which did not work:

defaults write com.rstudio.desktop CGFontRenderingFontSmoothingDisabled -bool NO
defaults -currentHost write com.rstudio.desktop AppleFontSmoothing -int 3

This seems to be tied to an issue in Chromium:
https://bugs.chromium.org/p/chromium/issues/detail?id=1005969

I'm checking in to see if any of the RStudio staff (@kevinushey, @jonathan) have thoughts on this topic before it automatically closes.

The issue is persistent on RStudio Desktop. It would be useful to have an option to enable subpixel antialiasing. For example, iTerm2 provides such an option under Preferences > Profiles > Text.