Shell does NOT open in RStudio Server With Tensorflow-GPU for AWS (

rstudioserver
aws
tensorflow

#1

I logged in to the server (version 1.1.419.aws.1) and tried to use the shell to change the user password as instructed. Nothing opens. Duh?


#2

Do you mind providing a bit more detail about what you are trying to accomplish? It sounds like you are trying to run the RStudio Server AMI here: https://aws.amazon.com/marketplace/pp/B0785SXYB2?qid=1534517542534&sr=0-2&ref_=srh_res_product_title

Is that accurate? And then what directions are you following to change the user password? Also, what are you looking to open? Are you trying to access RStudio Server in the browser and not finding it?

Are you familiar with setting up servers in AWS and the types of networking rules you need to set up for browser-based access?

EDIT: I have successfully found the instructions you mention (with help!). But your clarification on the other questions would still be helpful! Where in this process are you stuck?


#3

Cole,

I am wiping everything out and starting over from scratch. I'll document what I do and let you know if failure occurs. Thx.


#4

Cole,

Whereas my previous problem was that I could not access the shell within the RStudio instance provided via the Marketplace, I now find that (after closing out everything) and resubscribing to the Marketplace, I cannot access the server via EC2 Management Console or via the Marketplace.

I tried using: (1) a webpage with IP-address:8787 and (2) putty (with same IP-address. Not even a prompt.

Help appreciated. BTW, I have successfully used AWS via the EC2 Management Console before.


#5

Are you using the Public URL / IP address? Have you checked out the networking rules you are attaching to the instance to be sure that the ports you are trying to connect to are accessible?

You do see the server running / up in your list of EC2 instances, correct?