Shiny app suddenly stopped displaying plots with no error message.

Everything was working fine and I have been demoing / working on this dashboard for weeks with working plots and aesthetics. Suddenly, one night when I ran the application again, none of the plots appeared -- all of the pickerInputs, boxes, images, text, etc are there and correct, but there is no sign of the plots anywhere -- no error messages either.

I am working on a company computer so maybe a firewall suddenly was enacted? I also started using shinyWidgets about an hour before the problem started. Though the pickerinputs were working and everything was fine for about an hour and now nothing. I've tried restarting my computer, uninstalling and re-installing r, deploying this app to rsconnect -- nothing has solved the problem.

Please help. I've reviewed my code for hours and can't find anything. I have asked several forums and nothing. I have ran the plots by themselves in RStudio just fine, but as soon as I deploy the app, it hppens.

1 Like

To clarify, the app works 100% when you run it from RStudio, but not when you deploy it to a remote server? I have never run into this issue myself, but perhaps you could look into checking r shiny logs?