shiny read_csv can't find function

Running an App in RStudio worked yesterday morning. I didn't change anything at all but it stopped running because there was a problem with shiny (that I stupidly didn't note at the time).

I then potentially did something more stupid and updated my packages. That didn't work so I updated to latest version of r.

I have:

Loading required package: shiny
Error in read_csv("CombinedDemographics19.csv") :
could not find function "read_csv"

Any ideas?

The readr package should be loaded by library(tidyverse) I think, and this will supply the function read_csv.

You could try adding the line


to ensure that it gets loaded (and don't forget to actually execute the line!)

If you run


you should get quite a bit of informative output as the packages are loaded.

Thanks when I ran library(tidyverse) in a new RScript I found problems with rlang and httpuv which thanks to the trusty internet I was able to resolve.

1 Like

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.