Shinyapps.io Deployment Issue: Document depends on package but is not installed error

Hello,

I have an issue that is very similar to the post here: https://community.rstudio.com/t/getting-error-while-publishing-application-on-rstudio-connect-package-not-installed-please-resolve-before-continuing/67563

I try to publish my single .Rmd Shiny app to shinyapps.io and it gives me this:

Error:

  • Document depends on package "bit" but it is not installed. Please
    resolve before continuing.

  • Document depends on package "bit64" but it is not installed. Please
    resolve before continuing.

  • Document depends on package "data.table" but it is not installed.
    Please resolve before continuing.

  • Document depends on package "ellipsis" but it is not installed.
    Please resolve before continuing.

  • Document depends on package "vctrs" but it is not installed. Please
    resolve before continuing.
    Execution halted

I can confirm that all the packages listed above ARE installed locally on my system and my app works just fine in a local environment. It only fails upon attempting to publish to my shinyapps.io account.

Is there any sort of way to get rsconnect to properly identify these packages and load them?

Many thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.