Returning an Error Upon Deployment


I am attempting to deploy my dashboard to the web via However, I am getting an error reading:
"An error has occurred

The application failed to start.

exit status 1"

The app is working perfectly when running locally. I have tried a number of different possible solutions including removing the setwd() command and removing any package install/library commands from the script. I have also tried a number of other trouble shooting methods. Any thoughts on what is causing this error?

Here is my full code: Apps/Full_Site.R at main · tylergimple/Apps · GitHub

Well, the first problem I can see in that file is that all your library calls are commented out so when deployed to, no library is going to get installed into the container for the app and no library is going to be loaded when the app starts.

If that doesn't solve your problem, we would need to see your app's logs to get an idea of what might be going wrong.

Thanks for this suggestion! I ran with the libraries loaded and the site deployed correctly. Here is the link Tyler's Website

However, some of the objects are coming back with an error saying:
"An error has occurred. Check your logs or contact the app author for clarification."

These objects work perfectly when running locally. Here are the logs. I am not 100% sure how to read them. Any thoughts on what is causing those objects to have that error?


Is that the full log? If so, is not very informative but very often when a container gets suddenly killed without any apparent reason, it is because it is running out of RAM memory. I think you might be loading too much packages, maybe more than what it is actually needed by your code.

Yes from what I can tell that is the full log. I have deleted all of the unnecessary packages and only am running about 10 now total. I am getting the same error when deploying on but the program is working perfectly when running locally. Here is the error I am receiving and a pic of my logs. Any other thoughts?

Site: Tyler's Website
Code: Apps/Full_Site.R at main · tylergimple/Apps · GitHub

Well now you are showing a different set of error messages, it seems data.table is complaining about being used over a dataframe class object and not having a suitable method for it, sadly, I don't use data.table so I'm not the ideal person to debug your code but hopefully someone else will.

hi andre, I think theres a typo in your response text, data.frame rather than data.table...

tgimple, in the future, could you please share code/text in the form of text for the forum, rather than an image. Its almost always a lot better that way.

Thanks for the heads up

Well what's weird is the app runs perfectly when being run locally so I don't think it is an issue with the data.frama and data.table issue. Could that cause a problem when being run locally vs. online?

You might not be executing the app locally in a clean global environment so it might work because of what it is already there. If you get an error message saying there is a problem with that and the app stops then, you have to at least start looking there and, It wouldn't heart your code to be consistent with your data types anyways.

You were right!! I had to change the data frames to data tables to get them to work properly with the melt function!

Thanks for your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.