shinyapps[system]: Out of memory! even after upgrading to 8GB plan

  1. I upgraded to basic plan which increases memory limit to 8GB

  2. I set options(rsconnect.max.bundle.size="xxlarge") # 8GB

  3. mem_used() = 523657272 which is under 8GB
    and I still get:

    shinyapps[system]: Out of memory!

When I try to deploy my app. What am I missing?

@tzalenski, that is the issue I am having with shinyapps.io, Worst part is they disconnect me from the instance completely and have to reload everytime. That can annoy people and will not wait. It would be nice if it loads slowly than totally disconnecting.

I am looking at building my own at digital oceans (sorry shinyapps.io). Read these two articles:

  1. https://deanattali.com/2015/05/09/setup-rstudio-shiny-server-digital-ocean/#user-libraries
  2. https://www.bjoern-hartmann.de/post/deploy-your-shinyapp-with-docker-instead-of-shinyapps.io/

Good luch

Setting the bundle size is for the size of the bundle when deploying your application, not the amount of memory when running your application. Furthermore, the bundle size is a number, not the instance type string.

Make sure you have selected the appropriate application size. 8 GB is actually "xxxlarge".

@josh,
Based the discription for the Basin plan
DeepinScreenshot_select-area_20190617114637

In AWS speak, this is an Auto Scaling Group that spins new instance based on a certain threshold.
So you have an instance with up to 8GB of RAM and can also get a second or third instance based on whatever criteria your ASG is configured.

Based on what you wrote, under that plan you can select different instance sizes, in the case xxxlarge will give you the 8GB memory?

My question is let say I picked xxlarge with auto scaling, why would it run of memory? Does the auto scaling group setting not set to see that if an instance is at 70% utilization spin a second instance?

The additional instances are added based on connections.

See:

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.