<- shortcut (Alt+ -) doesn't work

rstudio
rstudiocloud

#1

In RStudio Desktop, I generally use the shortcut Alt + - to create the assignment operator <-. However, I tried it on RStudio Cloud (on my chromebook), and that just minimized the entire Chrome window. Does anyone know another way to shortcut the operator in RStudio Cloud?

Thanks!


#2

It is possible that the keyboard shortcut of RStudio is the same as one of Chrome, so the later prevent the use of the former.

You could try change the keyboard shortcut in RStudio see if it work in Rstudio Cloud, putting one that is not in conflict with chrome.


#3

Unfortunately at this time IDE settings are not shared between projects and you would need to alter the keyboard shortcut in each project. It is on our roadmap to improve this situation, but we don't have a timeframe to share at this time.

Your best best might be to change the Chrome OS keyboard shortcut(s) that conflict with those you use in the RStudio IDE, if that's possible.

I will also check with the IDE team as to whether they customize the shortcuts based on the OS in order to eliminate or minimize conflicts, as this would seem to be an issue if one were using a Chromebook with RStudio Server.