sliderInput() problem when running PCAshiny

I recently uptade R and Rstudio to get the last versions of each, and the package Factoshiny doesnt' work properly anymore.

When running PCAshiny on datasets (even the most simple datasets), the following message appears :

# An error has occurred!

In sliderInput(): min, max, and value cannot be NULL, NA, or empty.

I can't find what is the problem, I tried to uninstall and re-install packages and softwares ( R 4.0.3, Rstudio 1.4.1103). Any ideas ?

Can you provide a repr oducible ex ample (reprex) illustrating your issue?

You can use sessionInfo() after restarting R and running the code you shared above to show the version numbers for the packages involved

The session info are :

R version 4.0.3 (2020-10-10)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19041)

Matrix products: default

Random number generation:
RNG: Mersenne-Twister
Normal: Inversion
Sample: Rounding

locale:
[1] LC_COLLATE=French_France.1252 LC_CTYPE=French_France.1252 LC_MONETARY=French_France.1252
[4] LC_NUMERIC=C LC_TIME=French_France.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] Factoshiny_2.3 ggplot2_3.3.3 FactoInvestigate_1.7 shiny_1.6.0 FactoMineR_2.4

loaded via a namespace (and not attached):
[1] ggrepel_0.9.1 Rcpp_1.0.6 mvtnorm_1.1-1 lattice_0.20-41 tidyr_1.1.2
[6] digest_0.6.27 foreach_1.5.1 mime_0.9 R6_2.5.0 backports_1.2.1
[11] stats4_4.0.3 pcaPP_1.9-73 evaluate_0.14 colourpicker_1.1.0 pillar_1.4.7
[16] rlang_0.4.10 rstudioapi_0.13 miniUI_0.1.1.1 jquerylib_0.1.3 DT_0.17
[21] rmarkdown_2.6 htmlwidgets_1.5.3 munsell_0.5.0 tinytex_0.29 broom_0.7.4
[26] compiler_4.0.3 httpuv_1.5.5 xfun_0.20 pkgconfig_2.0.3 htmltools_0.5.1.1
[31] tcltk_4.0.3 flashClust_1.01-2 tidyselect_1.1.0 tibble_3.0.6 codetools_0.2-16
[36] rrcov_1.5-5 crayon_1.4.0 dplyr_1.0.3 withr_2.4.1 later_1.1.0.1
[41] MASS_7.3-53 leaps_3.1 grid_4.0.3 jsonlite_1.7.2 xtable_1.8-4
[46] gtable_0.3.0 lifecycle_0.2.0 magrittr_2.0.1 scales_1.1.1 cachem_1.0.1
[51] shinyjqui_0.3.3 promises_1.1.1 scatterplot3d_0.3-41 doParallel_1.0.16 mice_3.13.0
[56] robustbase_0.93-7 bslib_0.2.4 ellipsis_0.3.1 generics_0.1.0 vctrs_0.3.6
[61] iterators_1.0.13 tools_4.0.3 glue_1.4.2 DEoptimR_1.0-8 purrr_0.3.4
[66] parallel_4.0.3 fastmap_1.1.0 missMDA_1.18 colorspace_2.0-0 cluster_2.1.0
[71] shinydashboard_0.7.1 knitr_1.31 sass_0.3.1

I see you are using the latest version of shiny and I noticed in the release notes of 1.6, that the validation of sliderInput has changed. You can try to use a previous version of shiny
remotes::install_version("shiny", 1.5)

Since the error seems to come from a package that you are using, you can also create an issue at the github repo of this package.

I tried the previous version of the "shiny" package and everything is working now.

Thank you a lot for helping !

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

Here is the simple code and PCA I try to perform :
library(Factoshiny)
data(decathlon)
PCAshiny(decathlon)

Then I can't go further, the error message appears.