Solution to R bigquery: Exceeded rate limits when returning large amounts of data

After reading this discussion, " R bigrquery returns the following error: Exceeded rate limits", I found that these options worked for me:

  page_size = 1000000,
  max_connections = 3L,

Like this:

con1 <- dbConnect(
  project = "pjname",
  dataset = "ds_name",
  billing = "bill_name",
  page_size = 1000000,
  max_connections = 3L,

insert this code in your server-side and see
options(shiny.maxRequestSize=30*1024^2) #would increase the limit to 30MB.
hope it helps

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.