[SOLVED] RStudio not knitting rmarkdown with no error message

I don't think it's an issue of packages or what's in the rmarkdown file since everything was working, then I try again like 5min later and it processes and doesn't do anything. I've tried restarting RStudio, restarting my computer, and reinstalling R but none of it has worked. I'm using macOS Ventura 13.2, R version 4.3.0 (2023-04-21), and RStudio version 2023.06.2+561. If there's any other info any savior needs pls lmk.

Forgot to mention that I've also tried clearing the knitr cache and clearing the global environment

I finally fixed it. If anyone else is having this same issue, I traced it down to being an issue with the matlib library and OpenGL.


^^ this fixed it for me though
stack overflow where I got it from

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.