Source editor randomly become very glitchy (unable to select text, multi-line editing, inputs appear in wrong tab)

I've been dealing with this issue for about 6 months, and it has persisted across several versions of R and Rstudio (including older versions from before these issues started).

Periodically, and apparently at random, some tabs in the rstudio source editor would become very glitchy and even unusable. The main issues I have identified are:

  1. text selection with mouse click-drag stops working
  2. multi-line edit doesn't work or repeats all inputs with each key press since initiating multi-line
  3. multi-cursor edit only types in last location, and cursor stops showing
  4. shortcuts stop showing up, or worse, appear in another tab (can overwrite any selected text)

Here is gif of the worst offender (multi-line edit):
Gif shows initial shortcuts work in each tab, but then going back to second tab, shortcuts appear in 3rd tab. Not shown, but regular text input work in all tabs, but text select, and multi-line/cursor edits don't work in 2nd and 3rd tab.

Gifs of all other issues available on:

It is hard to troubleshoot, as it stops working after some time (sometimes minutes, sometimes days) and without any apparent trigger. The only thing that fixes the problem is terminating and restarting r-studio window (other windows can remain open).
I have tried completely uninstalling R and Rstudio, installing older versions, including reinstallation of both after deleting every folder associated with either and every reference of either in my registry (since some settings like colour theme were carried over across installations). The only thing I can think of that I haven't tried is reinstalling my OS.

Here is current session info:

> sessionInfo()
R version 4.3.0 (2023-04-21 ucrt)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 11 x64 (build 22621)

Matrix products: default

[1] LC_COLLATE=English_Canada.utf8  LC_CTYPE=English_Canada.utf8   
[3] LC_MONETARY=English_Canada.utf8 LC_NUMERIC=C                   
[5] LC_TIME=English_Canada.utf8    

time zone: <blocked out>
tzcode source: internal

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_4.3.0    tools_4.3.0       rstudioapi_0.15.0 Rcpp_1.0.10      
[5] codetools_0.2-19  terra_1.7-29     

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.