Special Character in File name - Windows - "The system cannot find the path specified"

Yes, I have a special character in my name path and as soon as RStudio opens it whines about it.

André is how it is on my Windows 11 User Profile Path.

Warning message:
In normalizePath(path.expand(path), winslash, mustWork) : path[1]="C:/Users/Andr� Davis/Documents": The system cannot find the path specified

Warning message:
In normalizePath(path.expand(path), winslash, mustWork) : path[1]="C:/Users/Andr� Davis/Documents": The system cannot find the path specified

What is the fix for this?

my solution is to modify windows environment variables
control panel/system/advanced system settings

  1. add an environment variable for R_USER
    1.1 variable name: R_USER
    1.2 click "Browse Directory" and select the path where the application is installed, then click "OK".
    for example: C:\Program Files\R\R-4.2.1

  2. modify the Path
    click "Browse Directory" and select the path where the application is installed, then click "OK".
    for example: C:\Program Files\R\R-4.2.1

How about a low tech solution? In Windows File Explorer, right click the folder name, and rename it without the special character.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.