ssh identification issue in RStudio

Slightly different problem to those seen on Forum before - I think.

Running RStudio on a Desktop and a Laptop (Both running Linux Mint 19.3). Have ssh keys set up for each, for ID purposes.

Having created a project on Github I can create the Projct in RStudio and files get copied from Github to the folders on both machines.

An ssh key is used to avoid username/password demands.

I can commit and push changes from my Laptop both from RStudio and the shell. On the Desktop however pushes and pulls are fine from the Shell but not from within RStudio where I get the following error message.

"sign_and_send_pubkey: signing failed: agent refused operation
git@github.com: Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists."

Seems bizarre it communicates when project is created in RStudio on the Desktop, but then doesn't recognise the repository!

Anybody either seen this and solved it or can offer advice on why it is happening?

Hi Gashead,

I don't have an answer, but I'm helping a colleague clone a private repository on GH and she's getting exactly the same error. Out of curiosity, what version of the IDE are you using? I don't think it matters, but it would help narrow it down.

Hi Phil

Thanks for prompt response, but I think you are right when you say it doesn't matter which version I run.

I'm running 1.3.766 on both laptop and desktop. Have uninstalled on Desktop and re-installed v1.2.5033 but am still having the same problem. Cannot push or pull using the IDE but can from command line. Interestingly it doesn't work from the shell when opened inside the IDE either (same error message). I have to open the shell from the Desktop to get pushes and pulls to work.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.