Starting Failed

[root@edgenodeson101 bin]# sudo rstudio-server verify-installation
Unable to find an installation of R on the system (which R didn't return valid output); Unable to locate R binary by scanning standard locations

Do you have R installed? (this is different than rstudio) if so, how do you have installed R? On which operating system are you?

We are going to need more information in order to help you

[root@edgenodeson101 ~]# wget https://download2.rstudio.org/rstudio-server-rhel-1.1.463-x86_64.rpm
--2019-02-25 16:33:04-- https://download2.rstudio.org/rstudio-server-rhel-1.1.463-x86_64.rpm
Connecting to 172.21.67.75:8080... connected.
Proxy request sent, awaiting response... 200 OK
Length: 45679532 (44M) [application/x-redhat-package-manager]
Saving to: ‘rstudio-server-rhel-1.1.463-x86_64.rpm’

100%[=============================================================================================================================>] 45,679,532 23.8MB/s in 1.8s

2019-02-25 16:33:07 (23.8 MB/s) - ‘rstudio-server-rhel-1.1.463-x86_64.rpm’ saved [45679532/45679532]

[root@edgenodeson101 ~]# yum install rstudio-server-rhel-1.1.463-x86_64.rpm
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Examining rstudio-server-rhel-1.1.463-x86_64.rpm: rstudio-server-1.1.463-1.x86_64
Marking rstudio-server-rhel-1.1.463-x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package rstudio-server.x86_64 0:1.1.463-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================================================================================
Package Arch Version Repository Size

Installing:
rstudio-server x86_64 1.1.463-1 /rstudio-server-rhel-1.1.463-x86_64 314 M

Transaction Summary

Install 1 Package

Total size: 314 M
Installed size: 314 M
Is this ok [y/d/N]: Y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : rstudio-server-1.1.463-1.x86_64 1/1
useradd: user 'rstudio-server' already exists
groupadd: group 'rstudio-server' already exists
rsession: no process found
Created symlink from /etc/systemd/system/multi-user.target.wants/rstudio-server.service to /etc/systemd/system/rstudio-server.service.
Job for rstudio-server.service failed because the control process exited with error code. See "systemctl status rstudio-server.service" and "journalctl -xe" for details.
● rstudio-server.service - RStudio Server
Loaded: loaded (/etc/systemd/system/rstudio-server.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2019-02-25 16:34:20 GMT; 1ms ago
Process: 60916 ExecStop=/usr/bin/killall -TERM rserver (code=exited, status=1/FAILURE)
Process: 60921 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=0/SUCCESS)
Main PID: 60923 (rserver)
CGroup: /system.slice/rstudio-server.service
└─60923 /usr/lib/rstudio-server/bin/rserver

Feb 25 16:34:20 edgenodeson101 systemd[1]: rstudio-server.service holdoff time over, scheduling restart.
Feb 25 16:34:20 edgenodeson101 systemd[1]: Starting RStudio Server...
Feb 25 16:34:20 edgenodeson101 systemd[1]: Started RStudio Server.
Verifying : rstudio-server-1.1.463-1.x86_64 1/1

Installed:
rstudio-server.x86_64 0:1.1.463-1

Complete!
[root@edgenodeson101 ~]#

Can you please describe what you're trying to show here?

1 Like

RStudio will not start

Windows 10 Pro

I installed R x64 3.5.2

I then installed Rstudio 1.1.463

R will start.

RStudio will not start. It only 'clocks' a bit.

No error messages

I tried CNTL RStudio with same result.

I've uninstalled and reinstalled numerous times (demonstrated my insanity)

This error implies that you've installed RStudio, but not R. Note that these are different pieces of software: R is the actual statistical software developed by R Core and contributors; RStudio is the front-end developed by the RStudio team. You likely need to run something like:

sudo yum install R

to get R installed on your machine a well.

R version 3.5.2 (2018-12-20) -- "Eggshell Igloo"
Copyright (C) 2018 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

Sys.which("R")
R
"C:\PROGRA~1\R\R-35~1.2\bin\x64\R.exe"